Application slow or unreachable
Incident Report for PayFit
Resolved
The application is now reachable.
Posted Jul 22, 2019 - 15:00 CEST
Update
We are continuing to investigate this issue.
Posted Jul 22, 2019 - 12:00 CEST
Investigating
We are currently investigating this issue
Posted Jul 22, 2019 - 11:00 CEST
This incident affected: Client Application.