PayFit app unusable
Incident Report for PayFit
Resolved
This incident has been fixed.
Posted 17 days ago. Aug 29, 2019 - 13:52 UTC
Investigating
We are experiencing issues with the PayFit application. Users cannot log into https://app.payfit.com/. Users who were already logged in cannot use the application.
Users can browse https://help.payfit.com but cannot submit requests.
We are investigating the issue.
Posted 17 days ago. Aug 29, 2019 - 13:43 UTC
This incident affected: Client Application and Help Center.