Holding actions impaired
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 14:05 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 23, 2021 - 11:22 CET
This incident affected: Client Application.