Help center not working in FR, GB, DE and ES
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 13:20 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 08, 2021 - 12:16 CEST
This incident affected: Help Center.