Actions related to teams & workflows impaired
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 20:03 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 16, 2021 - 18:51 CET
This incident affected: Client Application.