Employees are not displayed correctly in Spain
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 14:58 CEST
Investigating
We are currently investigating this issue.
Posted Apr 30, 2021 - 14:50 CEST
This incident affected: Client Application.