File preview, download and upload impaired
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Oct 27, 2020 - 16:07 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 27, 2020 - 15:52 CET
This incident affected: Client Application.