Admin actions impaired
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 18:30 CET
Identified
The issue has been identified and our teams are currently working on a fix.
Updates will follow when available.
Posted Feb 16, 2021 - 16:51 CET
Investigating
We're experiencing some difficulties for administrators and managers, regarding launch of validations and other actions.
Our teams are currently investigating the situation.
Posted Feb 16, 2021 - 16:44 CET
This incident affected: Public Website, Client Application, and Help Center.