The Payfit app is unavailable
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Oct 27, 2020 - 10:59 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 27, 2020 - 10:50 CET
Investigating
We are currently investigating this issue.
Posted Oct 27, 2020 - 09:53 CET
This incident affected: Client Application.