The PayFit app is slow
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Apr 29, 2020 - 18:03 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2020 - 17:02 CEST
This incident affected: Client Application.