Service degraded

Service degraded Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2023-09-18 09:27 CEST · 17 minutes

Updates

Resolved

The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

September 18, 2023 · 09:44 CEST
Monitoring

Our team has identified the root cause of the outage, and PayFit is gradually being restored. We are closely monitoring the situation and will continue to provide updates.

September 18, 2023 · 09:40 CEST
Issue

We are currently experiencing issues with our service, including the slow loading of certain pages. Our team is working hard to resolve the problem as soon as possible. We sincerely apologise for the inconvenience.

Impact: 🇫🇷 🇬🇧 🇪🇸 customers

September 18, 2023 · 09:27 CEST

← Back