Service unavailable

Service unavailable Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2023-08-24 15:30 CEST · 1 hour, 14 minutes

Updates

Resolved

The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

August 24, 2023 · 16:43 CEST
De-escalation

Our team has identified the root cause of the outage, and PayFit is gradually being restored. We are closely monitoring the situation and will continue to provide updates.

August 24, 2023 · 16:29 CEST
Investigating

We sincerely apologise; PayFit is currently unavailable due to a technical issue. Our team is actively working to restore access as soon as possible. We apologise for any disruption to your daily operations, and we will provide updates as they become available.

Impact: 🇫🇷 🇬🇧 🇪🇸 customers

August 24, 2023 · 15:41 CEST

← Back