Application slow or unreachable

Major incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2019-07-22 11:00 CEST · 3 hours, 59 minutes

Updates

Resolved

The application is now reachable.

July 22, 2019 · 17:02 CEST
Investigating

We are continuing to investigate this issue.

July 22, 2019 · 17:01 CEST
Investigating

We are currently investigating this issue

July 22, 2019 · 16:58 CEST

← Back