PayFit app unusable

Major incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations Help center
2019-08-29 15:43 CEST · 9 minutes

Updates

Resolved

This incident has been fixed.

August 29, 2019 · 15:52 CEST
Investigating

We are experiencing issues with the PayFit application. Users cannot log into https://app.payfit.com/. Users who were already logged in cannot use the application.
Users can browse https://help.payfit.com but cannot submit requests.
We are investigating the issue.

August 29, 2019 · 15:43 CEST

← Back