PayFit Application unavailable

Major incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations Help center
2019-10-14 11:34 CEST · 2 hours, 36 minutes

Updates

Resolved

The incident has been resolved.

October 14, 2019 · 14:10 CEST
Monitoring

A fix has been deployed and we are closely monitoring the application.

October 14, 2019 · 12:00 CEST
Update

The issue has been identified and we are working on a fix.

October 14, 2019 · 11:51 CEST
Investigating

We are experiencing issues with the PayFit application.
Users cannot access https://app.payfit.com/.
Users can browse https://help.payfit.com but cannot submit requests.
We are currently investigating this issue.

October 14, 2019 · 11:34 CEST

← Back