Application slow or unreachable

Major incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations Help center
2020-01-22 20:07 CEST · 42 minutes

Updates

Resolved

The incident has been resolved.

January 22, 2020 · 20:49 CEST
Monitoring

The Help Center and all the Application features are back online.

We are closely monitoring the situation of AWS.

January 22, 2020 · 20:43 CEST
Update

We are continuing to work on a fix for this issue.

January 22, 2020 · 20:27 CEST
Update

We are experimenting an issue which is affecting our Application capacity to send emails and the Help Center website.

This issue is related to the AWS outage declared at 10:25 AM PST.

We are closely monitoring the situation of AWS.

January 22, 2020 · 20:07 CEST

← Back