File preview, download and upload not possible on PayFit app

Minor incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2020-02-19 08:21 CEST · 39 minutes

Updates

Resolved

This incident has been resolved.

February 19, 2020 · 09:00 CEST
Investigating

We are continuing to investigate this issue.

February 19, 2020 · 08:29 CEST
Investigating

We are currently investigating this issue.

February 19, 2020 · 08:21 CEST

← Back