The Payfit app is unavailable

Minor incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2020-10-06 19:14 CEST · 32 minutes

Updates

Resolved

This incident has been resolved.

October 6, 2020 · 19:47 CEST
Investigating

We are currently investigating this issue.

October 6, 2020 · 19:14 CEST

← Back