File preview, download and upload impaired

Minor incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2020-10-27 15:52 CET · 15 minutes

Updates

Resolved

This incident has been resolved.

October 27, 2020 · 16:07 CET
Update

The issue has been identified and a fix is being implemented.

October 27, 2020 · 15:52 CET

← Back