Actions are not loading the Payfit app (UK Only)

Minor incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2021-02-02 10:38 CET · 26 minutes

Updates

Resolved

This incident has been resolved.

February 2, 2021 · 11:05 CET
Monitoring

A fix has been implemented and we are monitoring the results.

February 2, 2021 · 11:02 CET
Investigating

We are currently investigating this issue.

February 2, 2021 · 10:38 CET

← Back