Employees are not displayed correctly in Spain

Minor incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2021-04-30 14:50 CEST · 8 minutes

Updates

Resolved

This incident has been resolved.

April 30, 2021 · 14:58 CEST
Investigating

We are currently investigating this issue.

April 30, 2021 · 14:50 CEST

← Back