Application unreachable
Major incident
Login page
Payslip preview
Run Payroll
Leave management
Imports
Contract termination
Expenses
Standard integrations
2022-11-25 17:26 CET
· 2 hours, 16 minutes
Updates
Monitoring
November 25, 2022 · 19:31 CET
A fix has been implemented and we are monitoring the results.
Monitoring
November 25, 2022 · 18:34 CET
A fix has been implemented and we are monitoring the results.
← Back