The application is currently unavailable

Major incident Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations
2022-11-25 20:37 CEST · 3 hours, 11 minutes

Updates

Resolved

This incident has been resolved.

November 25, 2022 · 23:48 CEST
Monitoring

Incident is stable; we’re still closely monitoring the situation.

November 25, 2022 · 22:48 CEST
Update

The issue has been identified and a fix is being implemented.

November 25, 2022 · 20:37 CEST

← Back