The PayFit app is slow
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 18:49 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2020 - 18:29 CEST
Update
We are continuing to investigate this issue.
Posted Jul 01, 2020 - 18:15 CEST
Investigating
We are currently investigating this issue.
Posted Jul 01, 2020 - 18:15 CEST
This incident affected: Client Application.