The PayFit website is unavailable
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Jun 11, 2020 - 20:47 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2020 - 20:08 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jun 11, 2020 - 19:23 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 11, 2020 - 19:22 CEST
This incident affected: Public Website.