File preview, download and upload not possible on PayFit app
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 09:00 CET
Update
We are continuing to investigate this issue.
Posted Feb 19, 2020 - 08:29 CET
Investigating
We are currently investigating this issue.
Posted Feb 19, 2020 - 08:21 CET
This incident affected: Client Application.