The Payfit app is unavailable
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Oct 06, 2020 - 19:47 CEST
Investigating
We are currently investigating this issue.
Posted Oct 06, 2020 - 19:14 CEST
This incident affected: Client Application.