The PayFit app is currently unavailable
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Aug 01, 2020 - 21:39 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 01, 2020 - 20:38 CEST
This incident affected: Client Application.