File preview, download and upload not possible on PayFit app
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Jan 31, 2020 - 10:39 CET
Monitoring
A fix has been implemented and we are monitoring results.
Posted Jan 31, 2020 - 10:20 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 31, 2020 - 10:09 CET
Investigating
We are currently investigating the issue.
Posted Jan 31, 2020 - 09:48 CET
This incident affected: Client Application.