The PayFit app is slow
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 15:36 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 26, 2020 - 14:27 CEST
This incident affected: Client Application.