PayFit Application unavailable
Incident Report for PayFit
Resolved
The incident has been resolved.
Posted Oct 14, 2019 - 14:10 CEST
Monitoring
A fix has been deployed and we are closely monitoring the application.
Posted Oct 14, 2019 - 12:00 CEST
Identified
The issue has been identified and we are working on a fix.
Posted Oct 14, 2019 - 11:51 CEST
Investigating
We are experiencing issues with the PayFit application.
Users cannot access https://app.payfit.com/.
Users can browse https://help.payfit.com but cannot submit requests.
We are currently investigating this issue.
Posted Oct 14, 2019 - 11:34 CEST
This incident affected: Client Application and Help Center.