Degraded service: Unable to call back customers when requested
Service degraded
Help center
2026-09-17 10:07 CEST
· 15 minutes
Updates
Resolved
September 17, 2026 · 10:23 CEST
The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.
Issue
September 17, 2026 · 09:47 CEST
We are currently experiencing issues with our ability to call back customers who request it. Our team is working hard to resolve the problem as soon as possible. We sincerely apologise for the inconvenience.
Impact: 🇫🇷
← Back
Payfit Status