Service degraded
Service unavailable
Leave management
Expenses
2025-04-01 11:43 CEST
ยท 54 minutes
Updates
Resolved
April 1, 2025 ยท 12:36 CEST
The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.
Issue
April 1, 2025 ยท 11:43 CEST
We are currently experiencing issues with our service, including the slow loading of certain pages. Our team is working hard to resolve the problem as soon as possible. We sincerely apologise for the inconvenience.
Impact: ๐ซ๐ท ๐ฌ๐ง ๐ช๐ธ customers
โ Back