Service fully restored
      
Service degraded
      
        Payslip preview
    
    
      
2025-02-03 09:36 CET
      
      · 23 hours, 57 minutes
    
  Updates
          Resolved
        
        
February  4, 2025 · 09:33 CET
        
      
      The outage has been resolved, and Payslip preview is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.
          Issue
        
        
February  3, 2025 · 09:36 CET
        
      
  The outage has been resolved, and Payslip preview is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.
← Back
 PayFit Status
            
PayFit Status