Service fully restored
Service unavailable
Run Payroll
2024-11-27 12:13 CET
· 54 minutes
Updates
Resolved
November 27, 2024 · 13:07 CET
The outage has been resolved, and payroll closing is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.
Issue
November 27, 2024 · 12:13 CET
The outage has been resolved, and payroll closing is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.
← Back