Service degraded

Service degraded Payslip preview
2024-11-18 17:41 CET ยท 55 minutes

Updates

Resolved

The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

November 18, 2024 ยท 18:36 CET
Issue

We are currently experiencing issues with our service, including the slow loading of certain pages. Our team is working hard to resolve the problem as soon as possible. We sincerely apologise for the inconvenience.

Impact: ๐Ÿ‡ซ๐Ÿ‡ท ๐Ÿ‡ฌ๐Ÿ‡ง ๐Ÿ‡ช๐Ÿ‡ธ customers

November 18, 2024 ยท 17:41 CET

โ† Back