Service gradually restored
      
Service degraded
      
        Payslip preview
        Run Payroll
        Leave management
        Imports
        Contract termination
    
    
      
2024-08-27 10:10 CEST
      
      · 1 day, 3 hours, 26 minutes
    
  Updates
          Resolved
        
        
August 28, 2024 · 13:37 CEST
        
      
      The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.
          De-escalation
        
        
August 27, 2024 · 14:53 CEST
        
      
      Our team has identified the root cause of the outage, and PayFit is gradually being restored. We are closely monitoring the situation and will continue to provide updates.
          Monitoring
        
        
August 27, 2024 · 13:18 CEST
        
      
      Our team has identified the root cause of the outage, and PayFit is gradually being restored. We are closely monitoring the situation and will continue to provide updates.
          Monitoring
        
        
August 27, 2024 · 10:10 CEST
        
      
  Our team has identified the root cause of the outage, and PayFit is gradually being restored. We are closely monitoring the situation and will continue to provide updates.
← Back
            
PayFit Status