Service gradually restored

Service degraded Login page Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations Help center Custom integrations
2024-07-29 09:06 CEST · 2 hours, 18 minutes

Updates

Resolved

The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

July 29, 2024 · 11:24 CEST
Investigating

We are still investigating. Major slowness is experienced around the entire app, with some feature (e.g. leave management) being totally unresponsive.

July 29, 2024 · 09:53 CEST
Monitoring

Our team has identified the root cause of the outage, and PayFit is gradually being restored. We are closely monitoring the situation and will continue to provide updates.

July 29, 2024 · 09:06 CEST

← Back