Service degraded

Service unavailable Payslip preview Run Payroll
2024-07-25 16:52 CEST · 35 minutes

Updates

Resolved

The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

July 25, 2024 · 17:27 CEST
Investigating

The outage has been resolved. PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

July 25, 2024 · 17:25 CEST
Issue

We sincerely apologize; payroll closing and payslip preview are currently unavailable. Our team is working hard to resolve the problem as soon as possible. We sincerely apologise for the inconvenience.

Impact: 🇫🇷 🇬🇧 🇪🇸 customers

July 25, 2024 · 16:52 CEST

← Back