Service degraded

Service degraded Payslip preview Run Payroll Leave management Imports Contract termination Expenses Standard integrations Custom integrations
2024-06-26 14:51 CEST ยท 54 minutes

Updates

Resolved

The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

June 26, 2024 ยท 15:45 CEST
Issue

We are currently experiencing issues with our service, including the slow loading of certain pages. Our team is working hard to resolve the problem as soon as possible. We sincerely apologise for the inconvenience.

Impact: ๐Ÿ‡ซ๐Ÿ‡ท ๐Ÿ‡ฌ๐Ÿ‡ง ๐Ÿ‡ช๐Ÿ‡ธ customers

June 26, 2024 ยท 14:51 CEST

โ† Back