Service degraded
Service degraded
Login page
Payslip preview
Run Payroll
Leave management
Imports
Contract termination
Expenses
Standard integrations
2024-06-25 16:17 CEST
· 2 hours, 6 minutes
Updates
Resolved
June 25, 2024 · 18:24 CEST
The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.
Monitoring
June 25, 2024 · 16:30 CEST
Our team has identified the root cause of the outage, and PayFit is gradually being restored. We are closely monitoring the situation and will continue to provide updates.
Monitoring
June 25, 2024 · 16:17 CEST
We are currently experiencing issues with our service, including the slow loading of certain pages. Our team is working hard to resolve the problem as soon as possible. We sincerely apologise for the inconvenience.
Impact: 🇫🇷 🇬🇧 🇪🇸 customers
← Back