Undo payroll service unavailable

Service unavailable Run Payroll
2024-01-26 16:46 CEST ยท 1 hour, 7 minutes

Updates

Resolved

The Undo Payroll service is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

January 26, 2024 ยท 17:52 CEST
Issue

Please note that Undo Payroll service is temporarily unavailable. We apologize in advance for any inconvenience this may cause you and your business. Thank you for your understanding.

Impact: ๐Ÿ‡ซ๐Ÿ‡ท ๐Ÿ‡ฌ๐Ÿ‡ง ๐Ÿ‡ช๐Ÿ‡ธ customers

January 26, 2024 ยท 16:46 CEST

โ† Back