Service unavailable

Service unavailable Payslip preview Leave management Imports Contract termination Expenses Standard integrations Help center
2023-12-06 23:08 CEST ยท 40 minutes

Updates

Resolved

The outage has been resolved, and PayFit is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

December 6, 2023 ยท 23:48 CEST
Investigating

We sincerely apologise; PayFit is currently unavailable due to a technical issue. Our team is actively working to restore access as soon as possible. We apologise for any disruption to your daily operations, and we will provide updates as they become available.

Impact: ๐Ÿ‡ซ๐Ÿ‡ท ๐Ÿ‡ฌ๐Ÿ‡ง ๐Ÿ‡ช๐Ÿ‡ธ customers

December 6, 2023 ยท 21:53 CEST

โ† Back