Service unavailable

Service unavailable Run Payroll
2023-12-01 09:27 CEST ยท 21 minutes, 1 second

Updates

Resolved

The outage has been resolved, and payroll closing is now fully operational. Thank you for your patience while we resolved this issue. We are working on ways to prevent similar incidents in the future.

December 1, 2023 ยท 09:48 CEST
Issue

We sincerely apologise; payroll closing is currently unavailable due to a technical issue. Our team is actively working to restore access as soon as possible. We apologise for any disruption to your daily operations, and we will provide updates as they become available.

Impact: ๐Ÿ‡ซ๐Ÿ‡ท ๐Ÿ‡ฌ๐Ÿ‡ง ๐Ÿ‡ช๐Ÿ‡ธ customers

December 1, 2023 ยท 09:27 CEST

โ† Back