https://payfit.com/es is displaying a blank page
Incident Report for PayFit
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 12:46 CEST
Investigating
We are currently investigating this issue.
Posted Jul 20, 2020 - 12:41 CEST
This incident affected: Public Website.